ЗАО «ЗЭО»

Пожалуйста, войдите или зарегистрируйтесь.

Расширенный поиск  

Новости:

Автор Тема: странное поведение преобразователя RS485-Ethernet((  (Прочитано 5655 раз)

0 Пользователей и 1 Гость просматривают эту тему.

lman

  • Newbie
  • *
  • Оффлайн Оффлайн
  • Сообщений: 43

Настоил сеть, пропинговал преобразователь и результат такой: 75% пакетов LOST.
В 80% случаев самостоятельный запуск ping сообщает о недоступности IP-адреса 10.42.42.48.
проверил ethernet-кабель, работает отлично, никаких потерь прии передаче не наблюдалось.
Запускал под лицензионной Win7 Pro:
В программе Eth485COnfig постоянно рвется соединение, не успеваю даже никуда толком нажать, и соединение разорвано. Я не говорю уже о настройках, до них вообще дело не доходит при этих разрывах..
Под лицензионной WinXP программа Eth485Conf вообще не запускается, пишет: "Ошибка при инициализации приложения (0xc0000022)"...
Как заставить работать это? Как такое ставить на объекты??
« Последнее редактирование: 28 Мая, 2013, 12:12:06 от lman »
Записан

Danila

  • Administrator
  • Hero Member
  • *****
  • Оффлайн Оффлайн
  • Сообщений: 703

Под WinXP программа Eth485Conf работает. Проверено на нескольких компьютерах. Видимо конфликтует с какой-то из установленной у вас программ.

Проверьте источник питания. Возможно, проседает напряжение, и устройство из-за этого перезагружается.

Если с напряжением все в порядке, то нужно передать нам преобразователь.
Записан

lman

  • Newbie
  • *
  • Оффлайн Оффлайн
  • Сообщений: 43

То, что проверено на Xp мне ни о чем не говорит, я говорю о конкретном случе, у меня не работает - и это главное для меня.
Источник стабилизированный TracoPower 24В, там ничего не проседает это точно.
Касательно передачи: вы мне оплатите доставку и туда и обратно?

« Последнее редактирование: 27 Мая, 2013, 19:09:40 от lman »
Записан

lman

  • Newbie
  • *
  • Оффлайн Оффлайн
  • Сообщений: 43

Да, и вот еще какая штука: сижу, работаю, воздух вокруг +24 градуса по Цельсию, плата как не работала нормально, так и не работает. Взял пирометр и померил температуру чипа 18F67, она составляет 52 градуса!
Это при 24 градуса окружающей среды. Есть опасения, что плата не сохранит стабильную работоспособность при температуре окружающей среды +70 градусов..
« Последнее редактирование: 28 Мая, 2013, 12:32:58 от lman »
Записан

lman

  • Newbie
  • *
  • Оффлайн Оффлайн
  • Сообщений: 43

в 3 часа ночи решил посмотреть в 40-ко кратный микроскоп на плату, ибо больше вариантов у меня не осталось.
оказалось, что между соседними ножками процессора находилась еле заметная даже под микроскопом тоненькая металлизированная(по всей видимости) сопля. удалил её и под Win7 обрывы связи прекратились.
под WinXP всё также не работает.

по этому поводу у меня просьба более тщательно проводить выходной контроль изделий, т.к. я убил на поиски целый день, а если такое будет выявлено на объекте, то данную неисправность можно будет искать целый месяц и не найти.

кроме того меня интересует работа данного изделия при температуре окр. среды +70 гр. Цельсия: нужны протоколы испытаний, т.к. иначе я не смогу ставить этих преобразователей на объект.

Каково среднее время наработки на отказ?
я вижу на плате электролитические конденсаторы(возможно я ошибаюсь), и они могут высохнуть через 3-5 лет, тогда изделие перестанет работать в промышленных условиях(мне нужно, чтобы работоспособность сохранялась не менее 10 лет).

Разъем питания крайне неудобен, вместо него гораздо лучше было бы поставить обычную клеммную колодку, тогда отпадет проблема с поиском разъемов, если монтаж осуществялется в промышленный шкаф.

« Последнее редактирование: 28 Мая, 2013, 12:38:41 от lman »
Записан